MacOS

Extremely disseminated among designers and content creators, you can also install and run OnSign TV on MacOS.

OnSign TV Minimum Requirements

  OSX 10.10 – Yosemite and above

  Mac-Mini 2014 Generation

  Mac-Mini 2018 Generation

Note: The OnSign TV Mac is an “Always on Top” application. It is possible to resize and minimize, but the application will always be shown as the topmost window.